Bienvenue sur RegardTV.net - Toute l'actualité sur la TV numérique en Suisse romande
Partagez
Voir le sujet précédentAller en basVoir le sujet suivant
guilhem63
Nouveau regard
Nouveau regard
Date d'inscription : 08/04/2012
Nombre de messages : 4
Localisation : Neuchâtel
Opérateur TV : Swisscom
Points : 2086
Réputation : 0

Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 08 2012, 21:37
Bonjour à toutes et tous,

Une courte présentation pour commencer : je suis un jeune homme de 24ans, récemment installé en Suisse pour le travail, et également nouvel abonné Swisscom. Je ne suis pas tout à fait débutant sur tout ce qui touche à l'informatique, mais il m'en reste encore beaucoup à apprendre comme ce qui m'a poussé à m'inscrire sur ce forum aujourd'hui : "Comment mettre un routeur Netgear WNDR4500 en réseau derrière la Swisscom Box ?".

Pour résumer la situation, j'habite dans un ancien immeuble dans lequel les signaux Wifi sont très atténués et je dispose de plusieurs appareils que je souhaiterais mettre en réseau (Lecteur Blu-Ray, HDD externe ...). Par conséquent, j'ai opté pour le dernier routeur Gigabit de Netgear avec des caractéristiques WLAN intéressantes, une gestion avancée du QoS et 2 ports USB pour le partage des disques.

Lorsque je branche le routeur Netgear sur mon modem/routeur Centro Grande de Swisscom sans modifier les paramètres par défaut, tout fonctionne à merveille. cependant, pour des soucis d’accès WAN et d'organisation du réseau, je souhaiterais utiliser la fonction de "Transparence IP" (et non le mode bridge) pour que mon nouveau routeur ai l'adresse IP WAN de ma connexion... mais à ce stade le Netgear n'a plus accés à Internet (alors qu'il a bien l'adresse IP publique de l'AP).

Les différents éléments de mon réseau sont configurés comme suit :

  • Swisscom box: reliée à la prise murale sur le port WAN

    • IP : 192.168.1.1
    • DHCP : 192.168.1.100 - 150
    • WLAN : Off
    • Transparence IP configurée pour l'adresse Mac du routeur Netgear WNDR4500

  • Routeur Netgear: relié à un port RJ45 de la Swisscom box par le port WAN

    • IP : 10.0.0.1
    • DHCP : 10.0.0.100 - 150
    • WLAN : On



Dans cette configuration, les 2 routeurs sont bien en full duplex 100Mb/s sur le port 1 du routeur Swisscom et le port WAN du Netgear mais impossible d’accéder à internet depuis le Netgear même si celui-ci a bien l'adresse IP WAN du premier. Quelqu'un sait-il comment procéder pour résoudre mon problème ? Paramétrage des identifiants Swisscom sur le Netgear ? Désactivation du filtrage NAT ? Je crois que Zebulon, un administrateur de ce forum a réussit à faire fonctionner une configuration similaire mais ce qui me surprend le plus c'est que pour moi, une fois la transparence IP activée le Netgear n'apparait plus en tant que "Périphérique connecté" sur la box Swisscom...

Merci d'avance pour votre retour et bonnes fêtes de Pâques à tous,

Guilhem63
avatar
Zebulon
Administrateur
Administrateur
Age : 41
Date d'inscription : 22/09/2008
Nombre de messages : 3263
Opérateur TV : Swisscom
Points : 6812
Réputation : 13

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Lun Avr 09 2012, 20:00
Bonjour guilhem63 et bienvenu sur ce forum!

@guilhem63 a écrit: Quelqu'un sait-il comment procéder pour résoudre mon problème ? Paramétrage des identifiants Swisscom sur le Netgear ? Désactivation du filtrage NAT ?

Non, il n'y a pas besoin de paramétrer des identifiants Swisscom sur le Netgear, ni la désactivation du filtrage NAT sur le routeur Swisscom (La transparence IP envoie tous les paquets sur le Netgear).

Tu as quel modèle de routeur Swisscom?
Lorsque la transparence IP est configurée, tu as bien ton IP Public et non pas privée sur le Netgear? Il t’attribue qu'elles adresses pour les DNS (toujours sur le Netgear)?

_________________
Abonnements TV : Swisscom Vivo M UHD - HD Français+ - Teleclub Sports - Netflix
Internet : Down-/Upload: 100'000 / 20'000 Kbits
Hardware : LG OLED55B6V - SONY KDL-46HX820 - CI+ Mini - PS4 - IPAD - NAS Synology DS412+ Plex server - Apple TV 4
NeoZ
Nouveau regard
Nouveau regard
Age : 42
Date d'inscription : 23/02/2012
Nombre de messages : 56
Opérateur TV : Swisscom
Points : 2191
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Mar Avr 10 2012, 12:08
Salut Guilhem63,
J'ai eu le même problème que toi, j'ai essayé de mettre un routeur derrière le modem swisscom et ce fut la Galère (d'ailleurs pas eu de solution..)
https://www.regardtv.net/t4568-cablage-modem
http://www.netgear-forum.com/forum/index.php?showtopic=72355&st=0&gopid=420417&#entry420417

Voici les liens où j'ai exposé le problème mais sans solution "finale" du moment que je fixais l'adresse IP manuellement du Netgear en 10.0.0.1 pas d'internet. La seule solution pour avoir internet avec le second modem, c'était de lui laisser une adresse IP donnée par la modem swisscom, et ensuite de lui donner la transparence IP pour cet IP. Mais ensuite je rencontrais des problèmes pour accèder à mon "ftp" depuis l'extérieur.
Ce qui est bizarre, c'est que la solution qui ne donne pas accès à internet, permet quand même d'accéder au FTP depuis l'extérieur ou bien de faire du Skype, va savoir pourquoi...
J'avais appeler le support swisscom et il m'avait parler du QoS et d'ouvrir un canal (mais cette fonction permet seulement de donner des priorités pour le débit (TV, internet,jeux, etc..)... En tout cas, si tu trouves la solution, redis-moi !!! Very Happy

_________________
Abonnements TV : Swisscom TV 2.0
Internet : Down-/Upload: 40'000 / 4'000 Kbits
Hardware : Samsung 55es7080 - Popcorn Hour A300 - PS3 320GB - IPAD 64 GB - Onkyo nr626 + KEF 305
guilhem63
Nouveau regard
Nouveau regard
Date d'inscription : 08/04/2012
Nombre de messages : 4
Localisation : Neuchâtel
Opérateur TV : Swisscom
Points : 2086
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Jeu Avr 12 2012, 22:10
@Zebulon a écrit:Bonjour guilhem63 et bienvenu sur ce forum!

@guilhem63 a écrit: Quelqu'un sait-il comment procéder pour résoudre mon problème ? Paramétrage des identifiants Swisscom sur le Netgear ? Désactivation du filtrage NAT ?

Non, il n'y a pas besoin de paramétrer des identifiants Swisscom sur le Netgear, ni la désactivation du filtrage NAT sur le routeur Swisscom (La transparence IP envoie tous les paquets sur le Netgear).

Tu as quel modèle de routeur Swisscom?
Lorsque la transparence IP est configurée, tu as bien ton IP Public et non pas privée sur le Netgear? Il t’attribue qu'elles adresses pour les DNS (toujours sur le Netgear)?

Bonjour Zebulon,

Mon routeur Swisscom est le Centro Grande en version Motorola, mais j'ai également un Centro Piccolo (i.e.: routeur sans WLAN).

Et oui, lorsque j'active la transparence IP, le Netgear possède bien l'adresse IP Publique fournie par Swisscom, mais à partir de là je ne peux plus accéder à Internet. Ton idée sur les DNS me semblait intéressante et je viens d'essayer ce soir, mais malheureusement en fixant les adresses DNS Swisscom et Open DNS ça ne marche pas plus ... Aurais-tu une autre idée par hasard ?
Le plus surprenant pour moi c'est que l'interface avancée du Netgear m'affiche que les 2 routeurs sont bien configurés (full duplex WAN, adresses IP cohérentes ...) mais pas d’accès internet et la box Swisscom affiche "IP passthrough is currently enabled for 0" alors que le Netgear est connecté avec le nom "WNDR4500" (et non "0").

@Neoz: Merci pour les liens, si jamais je trouve une solution, j'essaierai de poster un tuto clair et détaillé à ce sujet.

Bonne soirée à tous,

Guilhem63
guilhem63
Nouveau regard
Nouveau regard
Date d'inscription : 08/04/2012
Nombre de messages : 4
Localisation : Neuchâtel
Opérateur TV : Swisscom
Points : 2086
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Jeu Avr 12 2012, 22:38
Re,

Par curiosité, je viens de passer le routeur Swisscom en transparence d'IP pour le "User configured PC" et tout semble fonctionner pour le mieux : routeur Netgear avec adresse IP Publique, accès à internet ... La seule différence notable avec l'ancienne configuration est que le masque de sous-réseau entre le Netgear et le Swisscom est 255.255.252.0 au lieu de 255.255.255.255 (et bien sûr j'ai "IP passthrough is currently enabled for User configured PC" au lieu de "IP passthrough is currently enabled for 0" sur le Swisscom)

Dans l'aide du routeur Swisscom, il y a le texte suivant :
  • IP Passthrough
    The IP passthrough feature allows a single PC on the LAN to have the Router's public address assigned to it.
    If you select "User Configured PC", you must then configure a local PC to have the public WAN IP address.


Pourquoi est-ce que ce cela fonctionne dans ce cas alors que la transparence IP vers un périphérique défini de manière univoque par son adresse MAC me semble plus robuste comme solution ?
Comment est-ce qu'il serait possible de s'assurer que c'est bien le routeur Netgear a qui va être attribué la transparence IP ?

A bientôt,

Guilhem63
avatar
Zebulon
Administrateur
Administrateur
Age : 41
Date d'inscription : 22/09/2008
Nombre de messages : 3263
Opérateur TV : Swisscom
Points : 6812
Réputation : 13

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Ven Avr 13 2012, 08:17
C'est étrange, comment tu as configurés la transparence IP par MAC? En ligne de commande? A l'époque sur le Motorola ça n'existais pas, normalement dans le menu déroulant tu devrais voir le hostname de ton routeur (donc WNDR4500)et tu devrais avoir quelque chose comme "IP passthrough is currently enabled for WNDR4500" sur le Swisscom

_________________
Abonnements TV : Swisscom Vivo M UHD - HD Français+ - Teleclub Sports - Netflix
Internet : Down-/Upload: 100'000 / 20'000 Kbits
Hardware : LG OLED55B6V - SONY KDL-46HX820 - CI+ Mini - PS4 - IPAD - NAS Synology DS412+ Plex server - Apple TV 4
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Ven Avr 13 2012, 17:11
Bonjour,
Le double NAT est à éviter absolument, les paquets seront routés 2 fois.

En ce qui concerne la transparance IP, il faut bien comprendre comment marche un routeur DSL qui fait du NAT par défaut.

Quand le routeur est seul, il reçoit une adresse IP publique par le DHCP du provider.
C'est adresse est un "vraie" addresse ipv4 unique sur l'ensemble du réseau internet qui permet à ton routeur de recevoir et d'envoyer des paquets sur le web. Ces adresses étant très rares la plus part des providers n'accèptent de fournir qu'une seule adresse par ligne DSL.

Le routeur va se charger des taches suivantes :
- Attribuer des IPs privées à tes machines. Ces adresses n'existent pas sur le net, elles sont réservées pour des réseau privés.
- servir de passerelle et se charger de translatter l'adresses IP les paquets devant entrer et sortir de ton réseau interne utilisant des adresses IP privées vers ton adresse publique, par un mécanisme appeler le masquerading.

On a donc par exemple la config suivante :
ligne DSL => (86.141.13.12=ROUTEUR=10.10.10.1) => PCs 10.10.10.25, 26,...

Si on place 2 routeurs en mode NAT l'un derièer l'autre, on va effectuer cette opération 2 fois.

ligne DLS => (84.141.13.12=ROUTEUR1=10.10.10.1) => (10.10.10.20=ROUTEUR2=10.10.11.1) => PCs 10.10.11.25, 26,...

Ce n'est pas optimal tous les paquets sont translattés 2 fois, et doivent subir 2 fois le mécanisme de masqreading, mais c'est utilisable. Si tu veux que ton serveur web sur le PC 10.10.11.25 soit acessible de l'extérieur, tu devras dire au routeur1 de rediriger ce paquet vers l'interface d'entrée du routeur2, donc 10.10.10.20 et au routeur2 de rediriger ce paquet vers le pc 10.10.11.25.

L' IP Passtrough permet de rediriger l'adrresse ip publique du routeur 1 vers une autre interface. le premier routeur se tranforme alors en bridge comme si il y avait un cable entre son entrée et sa sortie. Dans ce genre de configuration on n'utilise généralement qu'un seul port de sortie du premier routeur qui se tranforme en fait en modem. Dans ce cas la chaine devient la suivante

ligne DSL => --modem-routeur1--- (84.141.13.12=ROUTREUR2=10.10.10.1) => PCs 10.10.10.25

Les autres ports du modem-routeur1 deviennet inutilisable pour l'accès web, (sauf si ton provider te donnes 2 adresses publiques). On ne conncte un pc dessus que pour l'admin du modem routeur 1. On revient dans le cas où il n'y a qu'un seul routeur qui fait du NAT dans le réseau, plus simple et plus perfo.

Maintenant le problème c'est qu'avec swisscom tv il faut que le routeur 2 gère également le QOS et le multicast,....
avatar
Zebulon
Administrateur
Administrateur
Age : 41
Date d'inscription : 22/09/2008
Nombre de messages : 3263
Opérateur TV : Swisscom
Points : 6812
Réputation : 13

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Ven Avr 13 2012, 17:57
@bibolette a écrit:

Les autres ports du modem-routeur1 deviennet inutilisable pour l'accès web, (sauf si ton provider te donnes 2 adresses publiques). On ne conncte un pc dessus que pour l'admin du modem routeur 1. On revient dans le cas où il n'y a qu'un seul routeur qui fait du NAT dans le réseau, plus simple et plus perfo.

Maintenant le problème c'est qu'avec swisscom tv il faut que le routeur 2 gère également le QOS et le multicast,....

Pourquoi le routeur 1 devient inutilisable? Chez moi en transparence IP il fonctionnait parfaitement, c'est aussi la raison pour laquelle il faut laisser bancher les Swisscom TV box sur le routeur 1. J'arrivais même a atteindre le réseau du routeur 1 depuis le routeur 2 (l'inverse n'est pas possible).

_________________
Abonnements TV : Swisscom Vivo M UHD - HD Français+ - Teleclub Sports - Netflix
Internet : Down-/Upload: 100'000 / 20'000 Kbits
Hardware : LG OLED55B6V - SONY KDL-46HX820 - CI+ Mini - PS4 - IPAD - NAS Synology DS412+ Plex server - Apple TV 4
guilhem63
Nouveau regard
Nouveau regard
Date d'inscription : 08/04/2012
Nombre de messages : 4
Localisation : Neuchâtel
Opérateur TV : Swisscom
Points : 2086
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Ven Avr 13 2012, 21:36
@Zebulon a écrit:
C'est étrange, comment tu as configurés la transparence IP par MAC? En ligne de commande? A l'époque sur le Motorola ça n'existais pas, normalement dans le menu déroulant tu devrais voir le hostname de ton routeur (donc WNDR4500)et tu devrais avoir quelque chose comme "IP passthrough is currently enabled for WNDR4500" sur le Swisscom

Bonjour Zébulon,

En fait, j'extrapole un peu en disant que j'ai configuré la transparence IP par MAC puisque j'ai associé un nom à l'adresse MAC de mon Netgear avant de paramétrer la transparence IP directement sur ce nom ... Par contre je suis d'accord avec toi, je devrais bien avoir le hostname de mon routeur dans la configuration de la transparence IP et "IP passthrough is currently enabled for WNDR4500" dans l'en-tête de l'onglet de configuration ... mais ce n'est pas le cas puisque le routeur devient "invisible" dans l'interface Swisscom.

@Zebulon a écrit:
@bibolette a écrit:

Les autres ports du modem-routeur1 deviennet inutilisable pour l'accès web, (sauf si ton provider te donnes 2 adresses publiques). On ne conncte un pc dessus que pour l'admin du modem routeur 1. On revient dans le cas où il n'y a qu'un seul routeur qui fait du NAT dans le réseau, plus simple et plus perfo.

Maintenant le problème c'est qu'avec swisscom tv il faut que le routeur 2 gère également le QOS et le multicast,....

Pourquoi le routeur 1 devient inutilisable? Chez moi en transparence IP il fonctionnait parfaitement, c'est aussi la raison pour laquelle il faut laisser bancher les Swisscom TV box sur le routeur 1. J'arrivais même a atteindre le réseau du routeur 1 depuis le routeur 2 (l'inverse n'est pas possible).

Bonjour Bibolette,

Je suis d'accord avec Zébulon à ce sujet, pour moi même en transparence IP la box TV branchée sur le routeur 1 fonctionne parfaitement ...
En tout cas, merci pour ces explications et surtout le rappel pour le QoS+Multicast, même si tout cela était assez clair dans mon esprit je pense qu'il était utile de reposer les bases pour ce post.

Bonne soirée,

Guilhem63
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Sam Avr 14 2012, 11:31
Je suis d'accord avec Zébulon à ce sujet, pour moi même en transparence IP la box TV branchée sur le routeur 1 fonctionne parfaitement

En effet j'ai mis volontairement une notion sous le tapis car je ne voulais pas trop compliquer l'explication ci-dessus.
Le diable se cache dans les détails, j'ai écrit:

Les autres ports du modem-routeur1 deviennent inutilisable pour l'accès web, (sauf si ton provider te donnes 2 adresses publiques)

Et c'est bien ce qui se passe avec swisscom, mais le fonctionnement est moins évident à expliquer car il faut ajouter une notion qui ne se passe pas au niveau IP mais au niveau Ethernet c'est le transparent bridging.

En fait le routeur 1 reçoit bien non pas une mais 2 adresses IPs sur son port externe. La première est traitée comme dans le cas 1 et le routeur fonctionne normalement. Puis tous les paquets à destination de la seconde IP sont modifiés au niveau ethernet pour que la destination soit l'adresse MAC du destinataire de l'IP passthrough.

C'est ce qu'on appelle le transparent bridging, mais là on est dans les couches bas niveaux des transmissions IP over ethernet, et il faut faire appel à la notion de propagation ARP, qui permet d'associer une ou plusieurs adresses IP à une adresse MAC. (pour ceux que cela intéresse ouvrez une invite de commande sous votre système d'exploitation favori et taper la commande "arp -a")

Au niveau de la configuration de la transparence IP, peu importe comment on déclare ceci dans le routeur, d'un point de vue des trames c'est bien l'adresse MAC qui est modifiée et le paramètre utilisé par la couche Ethernet est bien l'adresse MAC.

Mais si on donne le nom de la machine, on peut récupérer l’adresse IP par DNS et, dans un réseau Ethernet local, depuis l'adresse IP, récupérer l'adresse MAC au moyen des tables d'association ARP.

(Et pour ceux qui veulent encore plus de détails, les bons routeurs vont encore créer dynamiquement 2 vlan séparés,....)
jo_r
Nouveau regard
Nouveau regard
Date d'inscription : 16/05/2011
Nombre de messages : 10
Points : 2422
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Ven Avr 20 2012, 22:28
Bonjour,

Malgré toutes ces super explications techniquement très détaillées (merci, j'ai appris quelques choses), je galère depuis 4 jours pour mettre en place la redirection de ports entre mon Centro Piccolo de Swisscom et mon routeur wifi Netgear (avec ddwrt). Internet fonctionne. Mon but est de pouvoir me connecter sur mon nas depuis internet. Si quelqu'un pouvait m'aider, ce serait super sympa.
Pour info, j'ai testé la transparence ip et la nat standard et je n'y arrive pas. J'ai également passé le modem en mode bridge via telnet ce qui me semble être la solution la plus performante.
Pour ce qui est du mode bridge, j'ai lu qu'il fallait passer le modem en "full bridge" (je ne sais pas s'il a vraiment une importance) (j'ai pu le faire après avoir downgradé le firmware du modem).
J'ai trouvé deux informations un peu contradictoires :
1. il faudrait configurer le port wan en dhcp sur le serveur
2. il faudrait configurer le port wan en pppoe sur le serveur (j'ai testé en mettant le username/password de Swisscom)
Qu'elle est la bonne ?

Après avoir passé le modem en mode bridge, je l'ai redémarré et j'ai connecté mon laptop en ethernet. Puis j'ai créé une connexion pppoe via le panneau de configuration pour tester. Ca ne fonctionne pas !
Le dessin sur l'interface web m'indique que je n'ai pas internet (la led sur le modem m'indique que oui).

Voici ma config:
(sur l'un des ports ethernet du modem, il y a un petit dessin et je ne sais pas ce qu'il représente mais j'ai branché le câble ethernet sur l'un d'entre eux et l'autre bout sur le port wan de mon routeur; comme ça ne fonctionnait pas j'ai essayé avec l'autre port ethernet mais ça ne change rien)

modem centro piccolo :
ip 192.168.1.1
dhcp désactivé


routeur Netgear :
wan ip 192.168.1.2

lan ip 192.168.69.1
subnet 255.255.255.0
gateway 192.168.1.1
(dans la configuration avancée réseau, j'ai mis le routeur en mode Gateway)

dhcp activé

nas disksation :
ip 192.168.69.3


Merci par avance pour votre aide et bon week-end.
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Ven Avr 20 2012, 23:41
Y a-t-il une raison quelconque qui fait que tu as besoin de 2 sous réseaux avec des plages d'adressages différentes ? (Sécurité ???)

Si ce n'est pas le cas il faut faire travailler ton Netgear en bridge et pas en router.
Remets le picolo en tous standard (factory restet)

Sur le netgear
- Dans Basic Setup :
- Wan Disabled
- IP 192.168.1.253 (par ex, mais une adresse non distribuée par le DHCP du picolo)
- Mask 255.255.255.0
- Gateway et local DNS sur le picolo 192.168.1.1
- DHCP disabled
- Assign WAN to LAN activé si disponible

Puis tu connectes ton routeur au piccolo sur une prise LAN

Ainsi tu auras un réseau local avec une seule plage d'adressage. Le seul router actif sera le piccolo, et le netgear servira juste de passerelle entre le monde cablé et le monde WIFI

En suite il faudra rediriger les ports externes du piccolo sur le NAS, en fonction des services aux quels tu veux accéder depuis le WEB.
A quel(s) service du NAS veux-tu pouvoir accéder de l'extérieur ? (web,ftp,smb,...)
jo_r
Nouveau regard
Nouveau regard
Date d'inscription : 16/05/2011
Nombre de messages : 10
Points : 2422
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Sam Avr 21 2012, 12:46
Je ne suis pas un expert mais si le routeur Netgear est en mode routeur, il faut 2 vlans distincs non ? (le but du routeur étant justement de router des paquets... j'avais essayé de mettre les addresses wan et lan dans le même vlan mais ça ne fonctionnait pas)
Merci pour la réponse si rapide.
Ca m'embête quand-même pas mal car le firmware du routeur Netgear est très complet et je fais par exemple des réservations d'addresses ip au niveau dhcp et ta solution m'empêchera de la faire du coup.
Je compte activer le https (non pas http ;-)) et ftps si ça existe pour éviter de laisser ouvert ftp.

Merci pour ton aide.
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Sam Avr 21 2012, 13:44
Hello,
Le picolo fait deja le routage des paquets entre le WAN et le LAN. Il ne le fait pas trop mal donc la solution la plus simple c'est de l'utiliser lui pour le routage, mais ce n'est pas la seule solution.

Je te propose cette solution car le comportement du mode bridge du picolo me semble peu orthodoxe mais le routage marche pas trop mal.

Si tu veux beneficier du DCHP de dd-wrt, aucun problème du dsactive le DCHP du picolo et du active celui de DD-WRT. (Tu peux même pousser le vice jusqu’à faire tourner un serveur DCHP sur le NAS).

C'est ce que je fais sur mon réseau, mais avec l'ancien routeur motorolla.

Le motorolla a l'ip 10.10.99.252, mask 255.255.255.0.
Son serveur dchp est désactivé.

Un buffalo sous DD-WRT, sur l'ip 10.10.99.1 fait DCHP, et distribue les adresse 2 a 63 en utilisant DNSMasq. En statique DNS j'envoie aux machines 10.10.99.252 donc le routeur motorola.
Comme second DNS j'ai mis mon serveur 2008R2 interne, et comme 3eme 8.8.8.8 qui est le serveur de google, en cas de problème de DNS chez SC.

Afin que les machines reçoivent comme passerelle vers l’extérieure celle du motorolla dans service => service => DNSMasq, j'ai mis les settings suivants:

- DNSMasq enable
- Local DNS disable (le dns c'est le mot puis mon serveur puis google,....)
- No DNS rebind enable

Dans Additional option j'ai mis

interface=lan,br0
dhcp-option=br0,3,10.10.99.252
dhcp-option=lan,3,10.10.99.252

Ce qui fait que la passerelle servie par le DHCP est bien le motorolla et il n'y pas de re-ecriture des paquets sur le dd-wrt.


Reste que tu dois te poser la question de quels service du NAS tu veux accéder de l’extérieur.
jo_r
Nouveau regard
Nouveau regard
Date d'inscription : 16/05/2011
Nombre de messages : 10
Points : 2422
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Sam Avr 21 2012, 22:46
Alors je te fais confiance si tu me dis que le mode bridge du piccolo est pas top.
C'est ce que je pensais faire pour le dhcp. Je vais tester la config proposée (la tienne est top).
Merci.
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 22 2012, 00:46
Ok mais t'as toujours pas répondu à la question principale :
- Quels sont les services du NAS que tu veux rendre accessible de l'extérieur.

Cela va déterminer la config du NAT sur le picolo
jo_r
Nouveau regard
Nouveau regard
Date d'inscription : 16/05/2011
Nombre de messages : 10
Points : 2422
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 22 2012, 12:14
Salut,
Si, j'avais écris :
"Je compte activer le https (non pas http ;-)) et ftps si ça existe pour éviter de laisser ouvert ftp."
Quand je disais si ftps existe, je voulais dire sur le diskstation.
J'ai quand-même un petit soucis. Le fait de devoir utiliser un port lan au lieu du wan sur le routeur, il va me manquer un port. Je crois que j'avais lu quelque part qu'avert ddwrt il était possible d'utiliser le port wan comme lan... je vais chercher voir si je retrouve l'info.
jo_r
Nouveau regard
Nouveau regard
Date d'inscription : 16/05/2011
Nombre de messages : 10
Points : 2422
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 22 2012, 12:17
Je n'y pense que maintenant mais du coup je peux utiliser un des ports lan libre du modem piccolo. J'y perds juste en performance pour ce périphérique puisque le router est du gigabit. A voir si ça joue en termes de perfs.
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 22 2012, 22:18
On peut bridger le port wan sur le lan avec DD-WRT pour autant que le chip-set le supporte.
Chez moi c'est avec les vieux linksys wg54, mais pas sur le buffalo,... sur celui-ci la check box lan to wan est juste déco
jo_r
Nouveau regard
Nouveau regard
Date d'inscription : 16/05/2011
Nombre de messages : 10
Points : 2422
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Mar Avr 24 2012, 22:51
Salut,
Un grand merci, tout fonctionne à présent :-)
Myst
Regard habitué
Regard habitué
Date d'inscription : 03/06/2010
Nombre de messages : 135
Opérateur TV : Swisscom TV 2.0
Points : 2893
Réputation : 3

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Sam Avr 20 2013, 08:29
Bonjour à tous !
Venant de commander un routeur Netgear R6300 pour bénéficier d'un réseau plus rapide (aussi bien en Ethernet qu'en Wifi), j'ai lu avec intérêt vos posts ici :-)
Étant loin d'être un expert en réseaux, j'avoue avoir parfois eu un peu de peine à faire la distinction entre les différentes configurations proposées...
Voici ma situation, j'espère que vous pourrez me conseiller...
Idéalement, je souhaiterais n'utiliser le routeur Swisscom (Motorola) que comme modem, et laisser le Netgear gérer le réseau. Mais d'après ce que j'ai compris, ça peut poser potentiellement problème avec Swisscom Tv.
Si je résume la situation la plus simple lue ici, il me suffirait d'activer la transparence ip sur le Motorola (plutôt que de l'utiliser en mode bridge), brancher Swisscom Tv sur l'un de ses ports, et le Netgear sur un autre. C'est bien ça ?
Mais de cette manière, n'aurais-je pas de problème à accéder aux serveurs tournant sur un de mes pc (branché au Netgear)? Ni pour programmer mes enregistrements à distance sur la Tv ?
Je souhaite vraiment faire au plus simple, pour que Swisscom Tv fonctionne et mon réseau bénéficie du gain de vitesse, je n'ai pas besoin de sous-réseaux complexes :-)

Un grand merci d'avance du néophyte que je suis :-)
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 21 2013, 11:19
Hello,
Pour faire simple on va dire que la transparence IP est équivalente au bridge.

En étant pointilleux c'est pas vraiment juste car le bridge se fait au niveau 2 et la transparence IP au niveau 3, mais comme on ne parte ici que de communication IP c'est équivalent.

Dans ton cas le plus simple serait de :
- Désactiver le WiFi du motorola
- De désactiver le DHCP du motorola
- De laisser le motorola en mode routeur/NAT
- De connecter le R6300 au motorola par un prise LAN (NE PAS UTILISER LA PRISE INTERNET du routeur)


En procédant ainsi le R6300 ne travaillera pas comme routeur mais comme access point, switch et serveur DHCP.
Le routage vers l’extérieur et le QOS sera assuré par le Motorola assurant ainsi le QOS pour SCTV.

Tu peux essayer ensuite d'optimiser tes perfs WiFi ré-activant le WiF du Motorola et en mettant les appareils lents dessus.
Il faut savoir que la norme utilisée sera la norme la plus haute supportée par tous les appareils. Donc si tu a un vieux truc 802.11b (par exemple un vieux noxon) ce sera 11MBs maxi pour tout le monde. Donc tu peux isoler ce qui est b/g sur un des points d'accès WiFI et ce qui n/oe sur l'autre.

Attention aux canaux WiFI

A+
Myst
Regard habitué
Regard habitué
Date d'inscription : 03/06/2010
Nombre de messages : 135
Opérateur TV : Swisscom TV 2.0
Points : 2893
Réputation : 3

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 21 2013, 15:12
Hello,

Merci beaucoup pour ta réponse Smile
Je devrais recevoir le routeur demain, j'essayerai le cas que tu conseilles et remonterai le résultat.

Pour info, pourquoi déconseilles-tu d'utiliser la transparence IP dans ma situation ? J'avais cru comprendre que c'était plus simple, vu que le motorola ne servait plus que de modem ensuite (tout en continuant de gérer le QOS pour Swisscom TV, mais j'ai peut-être mal compris)

Sinon, dans ce que tu conseilles, je ne vais pas avoir de double NAT, du coup ?

Dernière question (peut-être idiote), si je désactive le DHCP sur le Motorola, et le laisse activer seulement sur le Netgear, il n'y aura pas de souci avec Swisscom TV qui restera branché sur le Motorola ? Je pourrai attribuer une IP fixe au boîtier TV depuis l'interface web du Motorola ?

Encore désolé si j'ai posé des questions stupides, et merci encore pour tes conseils Smile

A+
bibolette
Regard incrusté
Regard incrusté
Age : 46
Date d'inscription : 06/09/2006
Nombre de messages : 742
Localisation : Vaud
Opérateur TV : TNTSAT + SRG (Sat) + !! RESILIE : Canal Sat Suisse !! + C+ france HD (merci Fraçois)+ FTA Wavefrontier T90 sur 28.2°E,19.2°E,13°E,9°E,7°E et 5°W
Points : 4875
Réputation : 0

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 21 2013, 20:58
Ok j'ai un peu plus de temps ce soir.

Tu as 2 options :

La première est celle que tu décris.
- Le motorola en transparence IP
- Un RJ45 direct sur la SC Box
- Un RJ 45 entre le moto et la prise "internet" de le R63000
- Ton réseau derrière le R63000

Dans ce cas :
- la SC box va recevoir une IP public par ex 178.192.163.122
- le R63000 va recevoir une IP public par ex 178.192.163.123
- le R63000 va faire le NAT le DHCP la passerelle et le relai DNS pour ton LAN.

Ca va marcher avec les restrictions suivantes :
- La SC Box sera directement sur le Web sans NAT, donc si une faille est découverte dans la SC Box elle sera une cible privilégiée.
- Le trafic entre la SC et ton réseau se fera devra passer par le sub net commun, soit le WAN, donc le trafic passera un travers du motorolla et du SC63000 avec routage et les éventuelles problèmes de NAT.
- Tu auras 2 sub net séparés

La seconde est celle que je décris :
- Dans ce cas le motorola gardes les roles de passerelle et de relais DNS.
- Tu transfère le role de DHCP au R63000 (tu peux aussi le laisser sur le motorola, la config sera alors plus simple)
- Tu n'utilises PAS la prise internet du R6300, donc tu n'utilises pas son routeur interne

Dans ce cas tu le motorolla va faire le routage et le NAT de ton unique IP publique vers ton subnet unique.
L'aventage c'est que tout tes périphériques seron sur le même sous réseau privé. Donc les communications entre la SC et ton infra locale sera directe et sans routage. Le DCHP du motorola étant pourri le mieux c'est de pouvoir le désactiver. Mais dans ce cas la config du DHCP du R6300 sera un peu tricky.

Il faut procéder ainsi :
- L'IP LAN du motorolla par défaut est le 192.168.1.1 mask 255.255.255.0 Tu la laisse telle quelle.
- Tu connecte un PC directement au R6300 sans être connecté au réseau et tu lui mets l'IP 192.168.1.2 mask 255.255.255.0
- Tu paramètres son DHCP pour qu'il distribue les addresses pae ex de 192.168.1.62 à 128
- La partie tricky c'est qu'il faut qu'il distribue 192.168.1.1 comme passerelle par défaut (default gateway) et comme DNS. Sur certains routeurs c'est très simple sur d'autre juste impossible.
- Un fois ce c'est fait, sur ton PC tu fais un IPCONFIG /RENEW (en invite de commande, lancée comme admin)
- Tu fais un ipconfig /all et tu vérifies que l'ip et la passerelle sont ok
- Tu connecte le routeur sur le motorolla en utilisant une des prises LAN du 6300 et surtout pas la prise internet, tu te connectes dessus et tu coupes le DHCP.
- Tu redémarre tous tes appareils réseau pour qu'ils rafraichissent leur IP.

L'autre variante c'est de laisser le DCHP sur le moto.
Dans ce cas :
- Tu connecte un PC directement au R6300 sans être connecté au réseau et tu lui mets l'IP 192.168.1.2 mask 255.255.255.0
- Tu coupes le DCHP et le relai DNS du R6300
- Tu déconnecte le PC du R6300 et tu le connecte à ton réseau.
- Tu te connectes au moto et du vérife que le DCHP ne distribue pas l'addresse .2, tu lui fait par ex distribué des addresses dès .62
- Tu connecte le R6300 au moto en utilisant une des 4 prises réseau local (SANS UTILISER LA PRISE INTERNET)

Voilou
A+


Myst
Regard habitué
Regard habitué
Date d'inscription : 03/06/2010
Nombre de messages : 135
Opérateur TV : Swisscom TV 2.0
Points : 2893
Réputation : 3

Re: Installation d'un routeur en réseau avec la Swisscom Box

le Dim Avr 21 2013, 22:07
Merci beaucoup pour ta longue réponse et tes différentes propositions, c'est vraiment sympa Smile

Hmm, je comprends les désavantages de la transparence IP...Bon perso, je ne pense pas qu'il y aura de trafic entre la SC Box et mon réseau, je n'utilise pas la Box pour accéder à quoi que ce soit de partagé sur un autre périphérique. Par contre je comprends le problème de sécurité que ça implique...
Je garderai donc cette solution en dernier recours. Elle a au moins l'avantage d'être simple à mettre en place et configurer, apparemment Wink

Je pense essayer ta dernière proposition. Petit point dont je ne suis pas sûr :
Quand tu dis de connecter l'ordi au R6300 sans le connecter au réseau, c'est simplement que je branche l'ordi sur l'un des ports du routeur, sans le connecter au Motorola, c'est bien ça ?
Parce qu'ensuite tu indiques de déconnecter l'ordi du R6300 pour le connecter au réseau... Tu entends débrancher l'ordi du routeur pour le connecter sur mon réseau actuel (soit le Motorola) afin de le configurer, c'est bien ça ?
(On est bien d'accord que la SC Box reste connectée sur le Motorola dans toutes les situations que tu as proposées ?)

Désolé de faire mon lourd avec mes questions Razz
Je te remercie encore, j'essaie tout ça demain soir Wink
Voir le sujet précédentRevenir en hautVoir le sujet suivant
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum